文章 35
评论 44
浏览 98825
解决使用conda下载pytorch-gpu版本困难的问题(两行命令搞定)

解决使用conda下载pytorch-gpu版本困难的问题(两行命令搞定)

image.png

省流:解决办法是使用mamba代替conda,下载速度惊人

conda install mamba -c conda-forge

mamba install pytorch==1.12.1 torchvision==0.13.1 torchaudio==0.12.1 cudatoolkit=11.3 -c pytorch

问题1

conda install pytorch torchvision torchaudio pytorch-cuda=11.6 -c pytorch -c nvidia
使用pytorch官网给出的conda命令,会从国外源下载(-c pytoch -c nvidia),常常会出现网络问题。

问题2

conda install pytorch torchvision torchaudio pytorch-cuda=11.6
网上有些资料提到,去掉-c pytoch -c nvidia,使用国内源下载,比如北师大,阿里云。但实际情况是,使用国内源经常会下载pytorch的cpu版本。

根本原因:指定某一版本cudatoolkit下的指定版本的pytorch不在源(国内conda镜像源或因外源)中,导致某一版本cudatoolkit下的指定版本的pytorch无法被conda install找到,然而不凑巧的是,源中却有指定版本的pytorch,不过它是CPU版本。那么,conda install这个小机灵鬼自作主张的替你安装了这个版本。结果就是,你觉得明明安装的是GPU版pytorch,可是像是有种神秘力量让你最终得到的总是cpu版pytorch。

来源:https://windses.blog.csdn.net/article/details/125910538

因此网上的解决办法是先下载好指定版本的cudatoolkit
conda install cudatoolkit=XX -c http://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/linux-64/
但我进入镜像网页中只看到了几年前的版本。
Pastedimage20230217181628.png

因此这件事又不太好解决了

解决办法

mamba

  1. 相比于 conda,mamba 是用 c++重写了 conda 的部分功能,**运行效率显著提高,可以进行并行的下载,**使用 rpm 包管理工具中的 libsolv,可以更快的解决环境依赖问题,减少折磨人的Solving environment转圈圈的时间
  2. mamba 的使用也比较简单,首先使用 conda 安装 mamba,后面所有用到 conda 的地方,都可以使用 mamba 替换即可。

使用mamba,我的依赖问题解决了,显示下载的就是gpu版本,而且下载速度惊人,感觉可以抛弃conda了:)

conda install mamba -c conda-forge

mamba install pytorch==1.12.1 torchvision==0.13.1 torchaudio==0.12.1 cudatoolkit=11.3 -c pytorch

标题:解决使用conda下载pytorch-gpu版本困难的问题(两行命令搞定)
作者:abandon
地址:HTTPS://www.songsci.com/articles/2023/02/17/1676629623838.html

Life Is Like A Boat

取消